Function Names Should Say What They Do

Ambiguous function names make code hard to read.

Date newDate = date.add(5);

vs.

Date newDate = date.daysLater(5);

The second is explicit and makes sense while the first is ambiguous.



bj 2019-09-22